Chevelles.com banner

1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Have a 70 chevelle with hidden wipers, motor was bad so changed it with rebuilt from autozone. Seems to run on high in low position and low in high position. Also will not shut off and park without turning keyswitch on and off. Have looked at different sites for new switch but could only find one without hidden wipers. Whats the difference?

------------------
jim70
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
I found it, I found it!!! Thanks a lot John for the info. The link to Elree's info with the drawing did the trick. I finally realized that I didn't have a ground on the switch itself. Guess I took it off when I had the dash out. Didn't see a ground showing on the electrical prints unless I overlooked it which is possible. Thanks again for the info, even made my wife come see. Ha- jim70
 

·
Premium Member
Joined
·
451 Posts
I have been having problems with my wipers also. Sounds like it must be a grounding problem. But I keep reading about Elree's info and drwing that is supposed to be located at http://www.chevelles.com/forum/Forum22/HTML/002207.html, but I get an error 404 when I try to go there. I know some of the messages are old, but does anyone have the correct site link, or the info that was in it?
 

·
Registered
Joined
·
158 Posts
Well, I don't believe the hidden and un-hidden switches are the same. I tried a new unhidden switch on my '69 and it did some very weird things.
 

·
Registered
Joined
·
7,762 Posts
Originally posted by Larry:
Well, I don't believe the hidden and un-hidden switches are the same. I tried a new unhidden switch on my '69 and it did some very weird things.
Well OK. Usually some of the weird stuff happens when the switch isn't grounded.
 

·
Registered
Joined
·
132 Posts
The wipers work on a ground system, unlike most switchs,They must have a good ground.Good Luck.
 
1 - 10 of 10 Posts
Top