Chevelles.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I replaced the hoses and nozzles on my '69 El Camino and when I pushed the lever to test the washer, it came on and would not shut off. Since I was on my way out, I just disconnected one of the leads to the washer motor..
I have looked in the assembly book and it didn't help me much. I am guessing that the switch (contact) won't release. Would I find the switch behind the dash and the switch itself? Or are there any other troubleshooting suggestions? Thanks, Bonnie
 

·
Gold Founding Member
Joined
·
63,020 Posts
When the wash button is pushed it activates a relay inside the motor which releases a lever for one revolution of the motor then the lever is locked out back in it's neutral resting position.

Sounds like maybe the lever is not catching and not locking back out to is neutral position.
 

·
Registered
Joined
·
723 Posts
I had the same problem on my 70 vette some time ago. It isn't the switch in the car. As Dean says it is the lever catch setup inside the washer pump. there is a tiny spring pulling against the lever. Also the gear is plastic that it rests on. Likely a poor spring or plastic gear (pawl I think they call it) problem. Remove the plastic cover on your washer and watch it work. then take the entire washer assembly off the pump. Held on with 3 screws, probably 5\16 heads on screws. A manual would really help here. They are tricky to work on and kinda hard to explain here. Post back any specific questions when you get closer.
 
1 - 3 of 3 Posts
Top