Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
376 Posts
Discussion Starter · #1 ·
Hi all,

I replaced the windshield on my '68 Chevelle and I installed one with the built-in antenna, which was introduced on '70+ Chevelles.

Now the FM reception is marginal at best. All stations are very week and with a lot of static. I know that it is connected correctly to the stereo.

What is your experience with the windshield built-in antenna? What should I do?

Should I install an antenna signal amplifier? Will this improve the signal or just amplify the static?

Or, should I install another antenna and forget about it? I found another hidden antenna that goes behind the windshield on the inside. It is supposed to be good...

Thanks for your input,
Theo.
 

·
Registered
Joined
·
7,762 Posts
I've heard certain compounds, used to set the window, screw up reception. Maybe someone else can add to that. The one in my 72 windshield has worked for years.
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #3 ·
John,

If that's the case, I am screwed... I assumed that the windshield installers knew what they were doing. I noticed that the previous compound had remained soft. The one they used now hardened in one day. That's all I know...

Theo.
 

·
Registered
Joined
·
7,762 Posts
Is it plugged in really good under the hood? Maybe they screwed up the connector that's mounted under there. If so, I think (maybe, maybe) that I have another connector with the coax lead. If that looks like a problem, I could drop one in the mail if I can find it.
There's really not much else to this type of antenna.
 
1 - 4 of 4 Posts
Top