Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Premium Member
Joined
·
1,464 Posts
Discussion Starter · #1 ·
Which wire on my 66 goes to the starter? I think it is the purple wire. I can't get it to light up with my test light when I turn the key. I'm just using a battery to get power to the alt wire then a jumper to it. I get power to my other wires but my fuse block is not lighting up either. Where am I not getting power to?
 

·
Registered
Joined
·
7,762 Posts
There's a large wire on the horn relay that leads up to the bulkhead connector. That wire powers the fuseblock. Normally that wire, the wire from the alternator, and the wire from the battery all tie together on the horn relay terminal. Guessing that harness wire doesn't have power on it.
 

·
Premium Member
Joined
·
1,464 Posts
Discussion Starter · #3 ·
I have power at the horn relay. But not at the fuse block inside. My lights come on but not the rest.
 

·
Registered
Joined
·
7,762 Posts
On your 66 there is a red wire that comes into the car through the bulkhead connector. This is the line from the horn relay.
After it comes through the connector it splices into 4 other red wires. These go to:
cigarette lighter
ignition switch
headlights
fuseblock
Might check to see if you have power on the red wire at the ignition switch or cigarette lighter.
If not I'd follow those wires back to find the splice.
 

·
Premium Member
Joined
·
1,464 Posts
Discussion Starter · #5 ·
I have power going to the fuse block but all the fuses are dead. What gives?
 
1 - 5 of 5 Posts
Top