Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Everytime a touch my brakes, my fuse pops (tail light). My brake lights do not work and neither does the turn signal. HELP please!!! If anyone has any suggestions I would greatly appreiciate it. Thanks
 

·
Premium Member
Joined
·
2,836 Posts
You have a dead short to ground. Have you changed anything recently? Done any work to the seats or center consol, if so recheck your work. If not there is a plug to the taillights in the trunk of most chevelles. Start by disconnecting that and checking each wire with a volt meter
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
The only thing different is I have an alarm installed. I rechecked the wires, I noticed a wire connected to my turn signals (lighting circuit) and one connected to a light in the dash. I'll recheck the grounds tonight. Thanks
 

·
Registered
Joined
·
7,762 Posts
You could clip a test light across the tail light fuse clips instead of a fuse. If the light comes on there is a short. Disconnect things until the light goes off.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Thanks for the info, one of my grounds was disconnected by the firewall. The driver's side brake light is coming on, but the passenger side is not. I'll keep checking...
 

·
Registered
Joined
·
80 Posts
check to see if canceling cam is in the center, in off position (turning lever in center possition). Then check brakes. Mine was bad in a 65, it would not center it's self. One brake lamp would not light when not centered.

Tim
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
I'm going to check the cancelling cam and recheck the 'alarm' work this weekend. The brakes are finally working correctly, but I'll pull the steering wheel and see what the deal is with the turn signal assembly... Thanks
 
1 - 8 of 8 Posts
Top