Team Chevelle banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,683 Posts
Discussion Starter · #1 ·
My car just recently started poping when I torque it, mostly when im stopped in traffic then I hit the gas and the car or suspension twists a bit. I cant figure out where its at Ive been all over the suspension buts its hard to pin point it when you cant get it to pop when your under the car. I think its the rear suspension but originally I thought it was the front. Seems more on the passengers side too. I the front right tire on a ramp and it didnt pop, I pulled the rear right tire on the ramp and got a pop when I pulled it off.
any ideas or tips on how to find it?
 

·
Premium Member
Joined
·
4,988 Posts
Agree, one my be twisted out if the spring pocket. Check the castle nuts on the ball joints too. Ensure they are tight and have a cotter pin in place.
 

·
Registered
Joined
·
1,710 Posts
Also check the upper A-arm bolts where it attaches to the frame.
 

·
Premium Member
Joined
·
536 Posts
The pop could be the trunk floor or gas tank warping when the suspension twists. Also check body mount bushings. Maybe a mount bolt is loose or missing.

Another thing that might pop is a broken motor mount, but usually the driver's side fails first.
 

·
Premium Member
Joined
·
92 Posts
I'm so stupid - when I read the title of the thread, I thought that you had found a Protect-O-Plate hidden somewhere in your suspension. :clonk:
 

·
Registered
Joined
·
1,683 Posts
Discussion Starter · #8 ·
Well today I got the car in the air and went over all the bolts with the torque wrench, found out that the lower rear control arm bolts and a shock mount bolt was loose. Tightened them up and went through the rest of the suspension and body bolts and now Ive got no pop. Guess those were the culprit thanks for the help guys.
 
1 - 8 of 8 Posts
Top