Chevelles.com banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
984 Posts
Discussion Starter #1
i was sitting in heavy traffic yesterday with my 65 chevelle and it stopped running. felt like someone just shut off the ignition switch. it would not start again, i had it towed home (disgraceful!) I have a stock distributor with mallory ignition module and MSD capacitive discharge box. Is there any way to see which one of these is the culprit? Could it be anything else? I checked all the wiring connections and it is getting fuel.
 

·
Registered
Joined
·
1,525 Posts
But no spark? I'd check all the wiring with a multimeter. Juice to the coil, jump the MSD may be a few things you can check. It may indeed be your ignition switch. Bummer.
 

·
Registered
Joined
·
29 Posts
I agree with Gene, you'll have to check it over, and it IS a bummer. I'd rather stick my tongue to a metal fence post on a cold January morning then mess with an electrical problem! Just my .02.

Dave

------------------
Team Chevelle #373
69 SS Convertible
 

·
Registered
Joined
·
738 Posts
Jim, that has happened to me twice with my MSD ignition and my problem turned out to be a loose connection at the fuse block for the primary red power wire coming from the MSD box. Both times, I had traffic stopped and yelling at me, but fortunately I found the culprit before the tow! Let's not even discuss my fuel pump going out on me though!!
Now that stunk!

------------------
'70 Malibu - 383 'Fog Fed' Stroker! Houston, Texas Gold Member #39
Chevellz Alwayz!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top