Team Chevelle banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3,808 Posts
Discussion Starter · #1 ·
Hey everyone,

I did do a search before posting this, but what seems weird about my deal is the fact that it seemed to happen immediately.

It's my '65 Lemans, recently converted to a '72-up internal regulator alternator with a modified M&H harness. Had a strange "episode" with the EFI this afternoon where I had to restart the car pretty frequently, some prolonged cranking as well (my fault BTW, not the injection). Now the damn thing won't shut off with the key. Wondering if it's somehow related to the prolonged starter motor use, or just likely a coincedence.
Pertinent info: MSD 6AL, Blaster 2 coil, Performance Distributors stock rebuild 61A int-reg alternator (has made an awful humming noise since new), Speed-Pro EFI.
BTW I think the "GEN" light turns off with the key.
Thanks for the help!

------------------
Tony Nausieda
1970 SS 396-4??hp
1977 Caprice, roller SB406 (soon)
1966 Buick GS 4-sp vert SOLD!!
1965 Le Mans EFI'd 468, 4-sp
 

·
Registered
Joined
·
34 Posts
hey tony

It may be because of the MSD, although I can't figure out why it would keep a fuel injected car running if there was no power getting to the computer.

Perhaps you have a low-voltage leak to the main power for the computer and/or ignition circuits.

That'd be what i'd check first.

Or, maybe your Ignition switch (the one mounted down on the column, or in the dashboard, or whatever) is shorted out, or just dirty.

Electronic stuff doesn't like dirt. I had a bit of dirt in mine, and it would try and start the car itself if you moved the column the wrong way.

Just my .02

------------------
1979 Chevy Malibu with a mild 355.
My Car
Aaron "The Hammer" Robertson.
Youth And Hotrodding - A Car Club for Those Under 25
 

·
Premium Member
Joined
·
3,808 Posts
Discussion Starter · #4 ·
No diode in the harness, but I also don't have any remnants of the old external-reg wiring because I had M&H build me a new one, from scratch, with internal reg wiring. I have a main power feed attached to the lug on the back of the alternator, and two wires in a single plug (red/black I think) that plug into the side of the alternator. Where does this diode go in my case?

------------------
Tony Nausieda
1970 SS 396-4??hp
1977 Caprice, roller SB406 (soon)
1966 Buick GS 4-sp vert SOLD!!
1965 Le Mans EFI'd 468, 4-sp
 
1 - 5 of 5 Posts
Top