Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
Ok, last weekend I finally installed my gauge cluster in the dash The amp gauge acts strange At times, it "boings" around the wrong direction and then gets hung upside down. It may stay there awhile (180 degrees off). Later, it may revert back to normal after restarting the engine. While driving, it constantly "boings" back and forth around the center 0 point. I know that it will oscillate depending on electrical load, but I would think it would be moving back and forth smoothly, not so crazy like. Is this gauge bad or do I have an elect problem? I have always had what seems to be erratic regulator operation in the first few miles of driving and haven't converted the alt yet to an internal regulator type. But even after the car warms up and it seems that the regulator has settled down, no more lamp dimming, the gauge still has this "jitteryness."
 

·
Premium Member
Joined
·
7,043 Posts
So you don't feel lonesome... my '70 SS convertible had been sitting in a barn for quite some time before I bought it. The amp guage was pointing straight down, but the needle went in the correct direction. I was changing the hydraulic hoses on the top and running the top motor excessively to bleed the lines. After that, the guage corrected itself. I have no idea why it did this. However, this topic has come up before and others have had a similar experience.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top