Chevelles.com banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5,229 Posts
Discussion Starter #1
Cousin is installing new power windows in his 65 ragtop. Bought a kit from a company in IL, supposed to fit 64-65 GTO convertable. Windows go down so fast I'd worry about them when they stop!! However going up is VERY slow without the guide channel in the frame, Extremely slow/non-existent WITH the guide in place.

These are all new setups, been lubed well, guide channel even lubed up. With the switch on, glass can be pulled into place very easily, just seems the motor has no guts to move up. Glass is not too tight in channel.

Wiring is as supplied by the manufacturer, not thin spaghetti wire. Even ran a second ground from the door to the main body to ensure good current return. Suggestions greatly appriciated!
 

·
Registered
Joined
·
7,762 Posts
Don't have a real answer but how do they react if the car is running? The extra 2.5 volts make them work any better? If no change, both work the same, no binds, I'm guessing the motors lack torque.
 

·
Registered
Joined
·
1,241 Posts
"Q I just installed new weather stripping and my windows are slow going up.

A This is a common problem, and is due to the fact that aftermarket manufacturers do not make their products to the exact same thickness as the original. What we suggest is that you spray the weather stripping with silicone spray and run the window up and down a few times. If that does not work try sanding down the weather stripping using a 1200 or 1500 grit paper."

From: http://www.electric-life.com/preview/faqs.html
 

·
Registered
Joined
·
5,229 Posts
Discussion Starter #4
Thanks for the replies guys-he's already shaving the weatherstripping down a bit.

Suprising bit is how fast they go down v/s how slow they go up. Even with NO weatherstrip, they just creep up.
 

·
Registered
Joined
·
168 Posts
Is there any type of spring tension adjustment? Sounds like you need to have some spring tension going down and some assist coming up.
 

·
Registered
Joined
·
26 Posts
i know this may sound dumb, and is prob completely wrong...but is it possibly that you have the motors mounted upside down? my logic is the the window motors may use gravity to bring them down, and have teh motors run slower going down then up (working against gravity)....im just thinking...
jon
 

·
Registered
Joined
·
2,156 Posts
I have that same kit on my GTO. They work really well. Perhaps you have a defective switch?

Andrew
 
1 - 8 of 8 Posts
Top