Chevelles.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I'm having trouble with my 70 el.At any given time ,it will cause my tack jump all over the place, plus making my shift lite flash on and off. When these things are happening, the motor won't shut off, it seems to want to diesel, the only thing i can do , is shut off the fuel pump. And then iot goes away till the next time, any help will be great, thanks
 

·
Super Moderator
Joined
·
12,633 Posts
Rich,
John asked about the MSD because some cars require a diode in teh MSD circuit. Without it, they wont shut off. The tach problem sounds more like a bad ground to me. Make certain that the tach, MSD, etc. are all grounded directly to the engine block. No sheet metal screws into the firewall ! Also, if you have a truck mounted battery...run an actual ground cable up to the engine block..don't rely on the frame unless you have studs welded to the frame to attach the cable to. Even then, you need a ground cable from the frame to the engine block. Back when I was wiring, and re-wiring, race cars as a pArt time deal...90% of the problems were due to bad grounds.
Hope this helps,

------------------
Bill Koustenis
Advanced Automotive Machine
Waldorf Md

1971 Heavy Chevy - original owner
Team Chevelle #100
 

·
Registered
Joined
·
7,762 Posts
In and out today. If you didn't install the diode in the alternator line, here are the instructions.
Click on www.msdignition.com
Go to INSTRUCTION DOWNLOAD
Click on that
Click on MSD 6 SERIES
Download that file. The wiring instruction for fixing the problem are on page 8. The value of the diode is right next to the picture. You need to put it in the same way as the picture shows. Radio Shack has them.
 
1 - 5 of 5 Posts
Top