Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 18 of 18 Posts

·
Registered
Joined
·
738 Posts
Discussion Starter · #1 ·
I'm convinced that alternators across the world are out to get me.
You guys remember not long ago that my first PowerMaster 100amp unit was dead. Bench tested and all - nada, deceased. So, I sent it back to Summit and ordered a replacement. Bolted it on and waited until the brakes were finished. Got the Wilwoods' bled today and took her for a short cruise to bed-in the brakes.

When the RPM's got up to around 2,500, my cigarette lighter 'plug-in voltmeter' started to RAPIDLY climb and didn't slow down until it hit 15.8!! The guage started giving me an error message of "hi". Yeeeaaa, no kidding!! Started to smell an odor of burning alternator so I immediately dropped the RPM's and the volts started to drop again..whew! All of this happened with the MarkVIII fan on.

Got out and checked the battery and sure enough she built up too much pressure (boiling inside?) and had started to vent battery juice down the sides.
Good grief, this is nutz!


Called PM and they're saying it's definitely a bad unit...send it back - again. What's the deal with my BAD alternator luck? Should I be doing some sort of tribal dance just before I get a new one?

------------------
502 Rat Infested 1970 Malibu - Gold Member #39
Keep America Beautiful - Drive A Brute Force Chevelle!
http://pages.about.com/wescolby/personal.html
 

·
Registered
Joined
·
2,922 Posts
Man, after hearing about so many bad experiences with Powermaster products, I feel like I won the lottery!

I'm really sorry to hear that Wes. So they want to do another exchange? I think I'd shoot for a refund and go for one of those 95 Amp jobs that BB_Mike was talking about a week or so ago.

I'm definitely gonna start carrying my stock 63 amp Delco unit around with me just in case.

------------------
My Elky Page (updated 3-15-01)
"Think for yourself. Don't let popular opinion make your decisions for you."
Chad Landry
TC Member #643
'68 El Camino
 

·
Premium Member
Joined
·
2,658 Posts
At least Summit is good about exchanging them. When I had problems with the 100amp one wires(twice) I asked for a chrome stock external alt to have as a back up alt and they refunded the difference in cost. Its still in the box stored away but if I need it its there.
I went to the 105 amp CS Delco and all problems have been solved.

------------------
Elcaminos are special!

I'd rather walk around with a Chevrolet hubcap in my hand than drive a Ford


work in progress
Big James Elky(AKA Ol Paint)
another shot of Ol Paint
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #4 ·
Guys, I'm convinced that this thing is possessed. Now while cruising, it won't go past 13..usually 12.8 or 12.9 but nothing higher than 13, and that's with the mombo fan on. When the RPM's drop while stopped at a light in traffic, it goes down as low as 10.9. Weird...


A 1-wire East Coast Electric 110amp is on its' way.
Chad my friend, you've got the last working Powermaster on the planet!! I hope that yours keeps working the way it should.

Two different Powermaster techs told me that their units 'seem' to get a lot of 'gremlins' in them when shipped from their facilities to Summit and then from Summit on out to customers. Wonder why...anyone care to guess?
 

·
Registered
Joined
·
2,922 Posts
Now I know why mine works! I didn't buy it from Summit! I once got an alternator rebuild kit from Summit that didn't work. Maybe their electric parts are stored in a radiated area.???
That really is weird! Maybe you should send it back for credit and get your electrical parts elsewhere.

I don't feel like I won the lottery anymore.
I just feel like I was lucky that Summit was out of this unit when I needed an alternator.


------------------
My Elky Page (updated 3-15-01)
"Think for yourself. Don't let popular opinion make your decisions for you."
Chad Landry
TC Member #643
'68 El Camino
 

·
Premium Member
Joined
·
4,156 Posts
Great, one more thing to worry about.
I got my Powermaster from Summit last summer and it still works fine, but I use a clutch fan
I wonder what's gunna happen when I hook up the amps and subs. BTW it stays at 14.0-14.2 with everything on including fuel pump. I wonder if maybe these mark VIII fans are posessed


------------------
Steve Beuth

69 Malibu ZZ4-350
93 Camaro Z28
99 Silverado
Chevelle pics
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #7 ·
No Steve, it's me they're after. I can see them now, all huddled next to the PowerMaster dyno waiting their turn and chanting...."faulty for Wes
, faulty for Wes
, faulty for Wes
..." Their evil little things I tell you. They have a plan to make me 'mad' but I'm on to them.

The rest of you guys, watch your back!


[This message has been edited by Wes Colby (edited 03-18-2001).]
 

·
Registered
Joined
·
423 Posts
I guess I should never buy anything from Summit, what with being a "Wes". I'd hate to have his curse hit me also.

------------------
Wes. Vann
Technical Reference section
Gold Member #5
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #9 ·
Yea Wes, this Wes is scratching his head over it too.
It all started about a year ago when I 'bad mouthed' the high price I had to pay for a NAPA 63amp 1-wire 'rebuilt' alternator. Something like $78 and change. The thing died shortly thereafter - and they've (alternators world-wide) had it in for me ever since. I think it's a freaking conspiracy - yep!


Now if this East Coast Electric pulls the same stunt, I'm having my family check me in to the local hospital. I'll know more by Wednesday.
 

·
Registered
Joined
·
2,922 Posts
Have you ever known one of those guys who can't wear a watch without it stopping? Maybe you're like that with alternators....
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #11 ·
That could be the case here Chad...I'm just glad that the camshafts aren't angry with me too.
Could you imagine having to replace cam after cam after cam? What a nightemare!!

Let's see, did I ever bad mouth a bumpstick? - hmmmm, thinking, thinking...
 

·
Registered
Joined
·
994 Posts
Wes - I went through three Powermaster (one wire) chrome alternators before I got one that lasted more than one year

Even at that, the last one they gave me whines like a supercharger. It works perfect even if it does have a whine. Yes it can be annoying, but my buddy at the parts house gave me a five year 100% replacement warranty




------------------
Dale
Lowered '67 Elcamino
ZZ430HP / 4L60
"Canyon Carver"

www.chevelles.com/showroom/elkydriveway1.jpeg
 

·
Registered
Joined
·
290 Posts
Wo Wes your geting a taste of those nasty gremlins
When your fan gets here i am sure to perform EXORCISM to be rid of that electrickel virus
LOL.

------------------
http:/hometown.aol.com/ddppell/myhomepage/profile.html Don Pell 66 396Beaumont.Once bitten twice shy.
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #14 ·
Well Dale, now I don't feel so bad...seems like alot of folks are having similar problems with them - must be either a legit shipping gremlin or a real quality control issue. BTW, that whine you have may be the rear needle bearings screamin' at you. Had one do that to me while back in high school. Replaced the rear bearing and the noise was history.

Hey, nice replacement warranty you got there! I'm envious.


Don, no exorcism needed with the Black Magic (so it's not just a clever name afterall!) fan bro. Me and that fan were total buds...she worked like a charm and kept her 'cool'.


I may have you do a 'naked tribal dance' though for my replacement alternator arriving this Wednesday.
On second thought, what would your neighbors think? Nhaaaa...bad idea.
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #16 ·
No ZZ, that's not why.
Santa out of coal?! I'm sure he's got plenty to go around...I mean c'mon, this is Santa we're talking about here! Besides that, I've been a particularly good boy
this past year so I know that Santa didn't throw in bad alternators instead of lumps of coal.


The only 'unscientific pattern' I see is that if you buy the unit DIRECTLY from PowerMaster, the odds of gremlins showing up are nill. I base that only on Chad Landry's and Richard DeYoung's experiences thus far. They both bought from the company and both report perfect performance.
 

·
Registered
Joined
·
738 Posts
Discussion Starter · #17 ·
Well fella's, after doing the ancient "naked tribal dance" till sunrise early this morning, I set about the task of switching out the schitzo Powermaster for the East Coast 110amp unit. I'm thrilled to report that I am now measuring a solid 14.8 volts at idle and at speed with the 'tornado' fan on. It's not chrome
but it IS a quality piece with a built-in internal fan and lots of heat vents around the external casing. Runs much cooler than any alternator I've used.

Needless to say, this time around I'm not complaining about the cost...lest this one 'turn' on me too.
 

·
Registered
Joined
·
290 Posts
Glad to here your charging again down time is a bummer.For me it has been almost 7 mounths
but spring is around the courner


------------------
http:/hometown.aol.com/ddppell/myhomepage/profile.html
Don Pell 66 396 Beaumont.
Once bitten twice shy.
Don Pell 66 396Beaumont.
Once bitten twice shy
 
1 - 18 of 18 Posts
Top