Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter · #1 ·
just bought a 71 ss, tac works backwards. step on gas and it goes to zero. I have seen mention about a printed circut board,could this be the problem,all other gagues work, just what does this board do.thanks,

------------------
BILL TIRELLI MEMBER#280
1969 BLK CHEVELLE SS396 375HP 4SP 410 POSI
STATEN ISLAND NY
=http://hometown.aol.com/wtirelli/myhomepage/index.html
 

·
Premium Member
Joined
·
4,478 Posts
Bill,

I'm not sure of what you're referencing to, but there are 2 different circuit boards. One is the main obvious one that runs the back of the all the guages feeding power to all of the guages and lights. This is the flexible circuit board which is avaliable at restoration companies. If your other guages work, I doubt this is the problem--Unless the actuall tach connections are not making good contact to this.

In all likely hood, it's your tach's INTERNAL circuit board which is bad. Over the years, the contacts and traces pull away and solder joints give. This makes the tach work screwy, if at all. In this case (unless your an electronics tech) you need to send the tach away to a pro to have it repaired. These are not quick fixes if that is the case.

So step 1 one be look under the hood to make sure connects are good (points ignition--tach wire goes to negative coil connection) or HEI (tach wire goes to TAC terminal on cap).

step 2 would be to "pop the top" (remove the dash pad) and use a mirror to visually inspect rear circuit connections for anything suspecious (jury rigging wiring, burnt traces etc).

Step 3, dissamble dash
remove tach and send to specialist.


Joe



------------------
Creator of Team Chevelle's RADIO TECH for original audio questions and answers
 
1 - 2 of 2 Posts
Top