Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
4,962 Posts
Discussion Starter · #1 ·
OK, enough politics and soapboxing about jmw's post. Time for a simple mechanical question. I'm about to install a Petronix ignitor in my 71. The hot wire to the coil is a resistor wire which drops voltage to about 9 volts. This much we know. When I install the ignitor, do I use this same wire or do I need to run another wire to supply 12 volts to the coil?
 

·
Registered
Joined
·
13,141 Posts
I have talked to Neil Wilder numerous times, who is an engineer at PerTronix, says NOT to change anything! Just run the black wire as always to (-) on the coil and the red wire to (+) on the coil. Connect all other wires as before. Too easy!

------------------
 

·
Registered
Joined
·
79 Posts
I used the system in my boat several years ago and did not change anything. It worked like a charm.

Don
 

·
Registered
Joined
·
900 Posts
I installed the set about a month ago.Hooked it up just like the instructions said.OOPs not true... I didn't run the wires thru the advance window but both out the bottom of the dist. housing.System works great.Also regapped my plugs to .45. Good luck
 

·
Registered
Joined
·
13,141 Posts
I swear I do NOT know why they say to run the wires out the window. I remove the rubber grommet and use a small drill bit to slot the hole big enough for the 2 wires. Works like a champ.

------------------
 

·
Registered
Joined
·
4,962 Posts
Discussion Starter · #6 ·
Thanks a bunch guys. Now all I need to do is finish building my 350, POR 15 the exhaust manifolds, install the engine and so on, and so on....... Thanks again guys.
 
G

·
I found a PerTronix ignitor at "CBS Performance Automotive", $79 , (free shipping)
I've never heard of this company? , has anyone dealt with them?........ Has anyone found a better price on the ignitor?
Thanks , Jim (always with the questions)

[This message has been edited by Jim (edited 03-21-99).]
 

·
Premium Member
Joined
·
1,626 Posts
Jim-
Summit has em' for 60 something. www.summitracing.com
I put the ignitor in my car during the summer and like everyone else it works great! No more replacing of points, and I spent the extra saved money on new taylor wires and new plugs!


------------------
Steve
64SS-327-4spd
 
G

·
I bought the ignitor in March,it sat on the workbench until today. I installed it , it has all the correct clearances but the motor lacks the power that it had with the points.Any ideas on what to check?.......Thanks,Jim
 

·
Registered
Joined
·
162 Posts
Did you check to see that the timing is the same, before and after? I would call their tech support; I found them to be most helpful. --- Carl
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top