Team Chevelle banner
1 - 3 of 3 Posts

·
Premium Member
Joined
·
7,290 Posts
Discussion Starter · #1 ·
My 69 equiped with a ls 5 454 showed 190 degrees cruising normal(20-70 mph) speed if I droved real slow(under 20 mph) the temp would rise to 210 just in a few minutes (never trie how much it would rise) was at home and shutted it of. The previous owner had put some flexalite fan on the car removed it a changed to a 5 blade clutch fan a changed the thermostat to a new 160(only they had left at the store) with just the fan the temp went little cooler never got it up to 210 but still a bit over 200 when i droved it slow for a little while and it´s not warm out here yet. The new 160 termostate reduced the temp 5 degrees more. With the clutch fan I wasn´t able to use the shroud (homemade) so wonder what would be next in the system to check? The waterpump pulley and crankpulley is aftermarket maybe the problem is there? to small crank pulley? The rad looks good and is a three row but maybe it´s the problem? Shall I get a four row ar a alu? A shroud will ofcourse help the temp but are they doing anything at highway speeds? Going to fabricate or buy a shroud but not sure if thats the problem? Will a fan with more blades help?

Marcus
 

·
Premium Member
Joined
·
633 Posts
The fan shroud will definately help you cool your engine at idle and slow speeds. A four row radiater is really what you should have with your engine. :thumbsup:
 

·
Premium Member
Joined
·
1,182 Posts
My 69 equiped with a ls 5 454 showed 190 degrees cruising normal(20-70 mph) speed if I droved real slow(under 20 mph) the temp would rise to 210 just in a few minutes (never trie how much it would rise) was at home and shutted it of. The previous owner had put some flexalite fan on the car removed it a changed to a 5 blade clutch fan a changed the thermostat to a new 160(only they had left at the store) with just the fan the temp went little cooler never got it up to 210 but still a bit over 200 when i droved it slow for a little while and it´s not warm out here yet. The new 160 termostate reduced the temp 5 degrees more. With the clutch fan I wasn´t able to use the shroud (homemade) so wonder what would be next in the system to check? The waterpump pulley and crankpulley is aftermarket maybe the problem is there? to small crank pulley? The rad looks good and is a three row but maybe it´s the problem? Shall I get a four row ar a alu? A shroud will ofcourse help the temp but are they doing anything at highway speeds? Going to fabricate or buy a shroud but not sure if thats the problem? Will a fan with more blades help?

Marcus
Marcus
if your going for stock looks ... buy a shroud from GROUND UP . one of the sponcers here .
the 160 t/stat is only controling opening temp .. and stays open for the remainder of your driving , and will not modulate as the cooling system is not capable of bringing temps down to 160... so till the car is parked for a hour it wont close again ... make sence ?
Buy a 180 t/stat and shroud , then see where your at .
if you need a aluminm rad down the road for 30% more efficiency ... look to my web site here in the link .

Don
 
1 - 3 of 3 Posts
Top