Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi Guys,

I have an issue with my brakes.

When I apply the brakes, the 1st half of the pedal stroke feels great but then the pedal goes quite hard. My setup is:
  • Willwood discs front and back
  • Willwood Master Cylinder
  • 8 Inch brake booster
  • Crate ZZ502
The old brake boost was an 11inch and was starting to leak so I replaced it with a smaller 8inch booster. I had to go smaller as I also replaced the rocker covers and the 11inch would touch the covers.
I have re-bled the system multiple times as well as bench bled the Master Cylinder twice. I have checked that the pushrod is not fowling as it enters the Master Cylinder and that there is a slight gap between the pushrod and the master cylinder piston.
I have also replaced the vacuum hose that goes from the vacuum port on the carb to the check valve. An interesting thing I noticed when I 1st test drove it was that when I really pushed hard on the brake pedal the engine idle went really low like it was going to stall.
I'm yet to test that the vacuum from the carb is sufficient. I had also thought it might be a valve not sealing correctly.

Has anyone else had this issue?

Thank-you in advance
Brad
 

·
Premium Member
Joined
·
789 Posts
My Chevelle was a factory manual drum brake car. I converted it to an MP power disc set up. I had the same problem. If I hit the brakes 1 time fast it seemed ok. If I was slowing to a stop and gradually applying the brakes the would get hard like no power assist. I used the 8” booster also so it would clear the tall Big Block valve covers. My cam was a 600/600 lift cam so I wasn’t building lots of vacuum to begin with. I added a Summit Vacuum catch can and it helped a bunch. It stores the vacuum for the brake system so it’s there when you need it.
576F927C-A7D9-48EC-85FF-C9DB5F221D4A.jpeg
50D8E54D-7BA6-4A45-987A-C4CBFFAC3A97.png
 

·
Premium Member
Joined
·
12,456 Posts
They make tall valve covers that work with an 11 inch booster. They are called cheaters and are similar in appearance to factory valve covers.
 

·
Premium Member
Joined
·
311 Posts
Hi Guys,

I have an issue with my brakes.

When I apply the brakes, the 1st half of the pedal stroke feels great but then the pedal goes quite hard. My setup is:
  • Willwood discs front and back
  • Willwood Master Cylinder
  • 8 Inch brake booster
  • Crate ZZ502
The old brake boost was an 11inch and was starting to leak so I replaced it with a smaller 8inch booster. I had to go smaller as I also replaced the rocker covers and the 11inch would touch the covers.
I have re-bled the system multiple times as well as bench bled the Master Cylinder twice. I have checked that the pushrod is not fowling as it enters the Master Cylinder and that there is a slight gap between the pushrod and the master cylinder piston.
I have also replaced the vacuum hose that goes from the vacuum port on the carb to the check valve. An interesting thing I noticed when I 1st test drove it was that when I really pushed hard on the brake pedal the engine idle went really low like it was going to stall.
I'm yet to test that the vacuum from the carb is sufficient. I had also thought it might be a valve not sealing correctly.

Has anyone else had this issue?

Thank-you in advance
Brad
Disc brakes require a lot of line pressure to work well. Your old 11" booster helped develop much more line pressure than the single diaphragm* 8", if that's what you have now. If it is a single diaphragm booster, replacing it with a dual diaphragm booster will help a lot. As others mentioned, a vacuum canister will help store better vacuum from when you're decelerating. Last but best choice is go with a Hydraboost.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Disc brakes require a lot of line pressure to work well. Your old 11" booster helped develop much more line pressure than the single diaphragm* 8", if that's what you have now. If it is a single diaphragm booster, replacing it with a dual diaphragm booster will help a lot. As others mentioned, a vacuum canister will help store better vacuum from when you're decelerating. Last but best choice is go with a Hydraboost.
Hi, Thanks for that info. I do have a duel 8 inch booster and the vacuum tester used to check that the vacuum was more than sufficient. I had also been thinking about the Hydraboost....I've now stripped the car but when I reassemble I will go that route.

Cheers Brad
 

·
Registered
From Australia to the USA.
Joined
·
244 Posts
100% go hydroboost . Reach out to Tobin at Kore3
 
1 - 7 of 7 Posts
Top