Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
hello,
I just replaced my dash harness on my 70 Chevelle this weekend with an M&H Electric piece. It fit great. I have one problem though, previous to the harness swap, when I turned on my headlights at night I would have to rotate the leadlight pull knob sometimes in order for the lights to come on that illuminated the speedometer, fuel guage, etc. After the dash swap was made, the headlights come on, but no dash illumination lights; even if I twisted knob, still no illum. lights, so night driving is out of the question. Any ideas on what I might check? I am wondering if the problem is with my headlight/ pull knob unit, seeing how when the pull knob is activated, the illum. lights come on. Any of you experienced this before? Thanks in advance.
 

·
Registered
Joined
·
12 Posts
Sounds like you may have lost your ground, you might try taking and unplugging a dash light and taking a piece of wire grounding it and touching the other end to the dash light housing and see if it lights up? on some of the lights they have a plastic housing but if yiu look close there is a grounding tab that would touch the metal on dash housing. if that's not it check to see that you have voltage to light socket? Hope that helps.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top