Team Chevelle banner
1 - 3 of 3 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
hello,
I just replaced my dash harness on my 70 Chevelle this weekend with an M&H Electric piece. It fit great. I have one problem though, previous to the harness swap, when I turned on my headlights at night I would have to rotate the leadlight pull knob sometimes in order for the lights to come on that illuminated the speedometer, fuel guage, etc. After the dash swap was made, the headlights come on, but no dash illumination lights; even if I twisted knob, still no illum. lights, so night driving is out of the question. Any ideas on what I might check? I am wondering if the problem is with my headlight/ pull knob unit, seeing how when the pull knob is activated, the illum. lights come on. Any of you experienced this before? Thanks in advance.
 

·
Registered
Joined
·
7,758 Posts
Sounds like before you made the harness swap, you had to keep moving around the knob to find a spot where the lights would come on. This is a problem with the rheostat in the head light switch. Now things don't work at all. Think I got that right.
On the bottom of the fuse block there is a small fuse in the center. It is shorter than the other fuses. This is the dash lamp fuse. Check to see if it is good. If it is good and ONLY if it is good try this. With a jumper wire, jump between the BAT terminal on the fuse block and the right (not left) side of the short dash lamp fuse. It may arc slightly so touch the fuse and not the clip. See if the lights come on. If they do change out the head light switch. These are available over the counter and you don't need the special tool to remove the switch securing nut on your car (like some earlier models).


[This message has been edited by John_Muha (edited 12-10-2001).]
 
1 - 3 of 3 Posts
Top