Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi,all! Just finished with installing a new dash in my 68, and replaced the dash harness. Getting everything connected up again, and working, everything works but I may have to go to the firewall side, and wiggle the engine harness connector to get the wipers working, or might have to wiggle the forward lamp harness to get a left front turn signal working. the firewall side connections just seem like there is too much free play in them. From what I can tell the under hood wiring seems to be original, but intact. I've heard of guys cleaning and bending these connectors. What do you you clean them with? Also it is a M&H dash harness, and I've heard their underhood harnesses come with a di-electric grease inside the connectors. Would this grease help to "sure" up the connections, and where could I get any of this?? (Sorry about being windy--just trying to explain the problem!) Thanx - Al
 

·
Registered
Joined
·
7,762 Posts
Well, I've never bent around connector contacts but that's just me. Been a long time since I cleaned contacts but used to use a spray contact cleaner from an electronics house with a toothbrush. Dielectic grease is available at any chain auto store. Used in spark plug wire boots.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks for your reply, John! I think I'll try the spray-cleaner-toothbrush idea first, then go to the di-electric grease if nessasary! -Al
 
1 - 3 of 3 Posts
Top