Chevelles.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
732 Posts
Discussion Starter #1
i recently turned on my headlights and all of a sudden they don't work. the rear& dash work and when i turn just the parking lamps, all is fine until i pull the knob all the way, then the parking lamps go out and no head lights rear and dash are fine. HELP!!!! :confused: :(

thanks
john
 

·
Premium Member
Joined
·
4,477 Posts
What year???

On PRE-1968 cars, the parking lights up front ARE suppose to go out when you pull the headlight switch all the way out (turn on the headlamps).

First things, first, have you done ANY work up front, changed the front clip for restoration, or pulled out the radiator? Lights need good grounds, any upset grounds and you'll have problems.

Second thing, start stomping on the dimmer switch a couple times. Those things DO go bad, and that controls ALL the power to your headlights.

Next, take some voltage measurements with a voltmeter up front (at the headlight sockets). Green wires should have 12 volts when high beams are activated, tan wires should have 12 when low beams activated. Take measurements with the red test probe on the wires, and the black probe on a GOOD CLEAN GROUND.

If no voltage, I'd try to investigate the dimmer switch on the floor before you go to the work of checking out the light switch.
 

·
Registered
Joined
·
732 Posts
Discussion Starter #3
sorry, its a 66 chevelle. i thought the parking lights were supposed to stay on when headlights are on. they have always been on before this problem. thanks, i will check the dimmer switch first. its just weird how it happened all of a sudden. by the way, i did do a cam swop a few months ago but the lights were fine until now. :confused:

thanks again
john

ps, you guys on this list are great!!!!
 
1 - 3 of 3 Posts
Top