Chevelles.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
in my '69 chevelle i cannot figure out what the problem is with the lights in the speedometer and fuel guage. when i turn my headlights on these lights don't turn on. i checked and saw that of the 10 that illuminate these guages, 7 were blown up. so i just replaced them thinking they'd all work because they might be in series but they didn't. the brights bowtie lights up properly when i have the brights on and if i turn the headlight switch knob the interior dome light comes on too so i just figured that the ground was ok. just to make sure i checked both grounds. there was one from the switch to the metal frame of the gauges and one from the metal frame to a ground wire that runs into a big cluster of wires. neither one of these wires has current and are both secured to screws and show no corrosion. what's the purpose of 2 ground wires? any help with my problem would greatly be appreciated. thanks, andreas
 

·
Registered
Joined
·
119 Posts
I don't know if you have yet but have you checked the little fuse on the very left bottom on the panel is the smallest one on the panel it says inst lgts or something close to that, I can't think of anything ealse. Good Luck!

------------------
Steve

1969 Chevelle SS 396 435HP
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
my fuse doesn't have the fuses on the lower half named. the white writing came off i guess. i pulled that small fuse and looked at it and didn't look burned out even after i pulled it but did decide to put a temporary jumper in there. it turned out that the fuse was the problem even though i can't visually see it burned through. thanks for that suggestion. saved me lots of hastles.
 

·
Registered
Joined
·
119 Posts
No prob. anytime for a fellow Chevy man. I know how painful tracking down electrical problems can be haha, i've had my fair share of them.

------------------
Steve

1969 Chevelle SS 396 435HP
 
1 - 5 of 5 Posts
Top