Team Chevelle banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
200 Posts
Discussion Starter · #1 ·
I just purchased a 1971 El Camino. It is a standard model so far as it has a t350, and a 10 bolt. I haven't even hardley looked it over yet, but had to share the news!!:D I got it for a killer price, no engine, but came with a 305 builder in the bed. I will attach a pic or two. Let me know what you guys think. I think this one is going to get my perssonal touch as my chevelle was brought back to it's original state. Any suggestions or comments welcome as this is my first el camino that I have owned. Thanks for your support in advance!! Do I have the Chevelle sickness or what? Chef



 

·
Premium Member
Joined
·
200 Posts
Discussion Starter · #5 ·
Yep bought locally here in Tucson. I haven't decide what to do yet, but like the idea of muslenne blue with a black interior. I just need to build or find an engine right now. chef
 

·
Registered
Joined
·
14,557 Posts
Justin, How's the project? have you started messing with it yet? jim
 

·
Premium Member
Joined
·
119 Posts
Nice,you have the start of a great project, being a Arizona car means no rust in the normal spots but check around the rear window along the bottom and in the corners, elcaminos like to rust in those spots. as far as the motor goes a nice crate 350 from GM is cheap and is a good base for any performance improvements in the future. the 305 is a smog motor and is choked by the heads and bore size.take your time and search for info on this site,your questions should be answered here with no problems.welcome to the elcamino enthusiast world,lol and enjoyment
 

·
Registered
Joined
·
14,557 Posts

·
Premium Member
Joined
·
200 Posts
Discussion Starter · #10 ·
Thanks for all the support guys. I have gutted the interior short of the dash and shifter and will be getting to those today hopefully. I called about the trim and he had everypeice ,but the two I needed. I haven't heard about the engine, but may work to get it running. I will give plenty of updates as I am pretty motivated to get this one running. Have a great day. Justin
 

·
Premium Member
Joined
·
200 Posts
Discussion Starter · #11 ·
Well it has been awhile since I have updated this thread. I have done a lot although it really doesn't look like it. I have removed all the front shhet metal, radiator and core support, hood, all the ac components as well as the heater core. With all of that gone I decided to smooth the firewall and have been fighting the weather to get this done. I finally got to spray it today, so pics are attached. I ordered new suspension components so hopefully I can get those installed and move on to painting the frame and suspension components. Wish me luck and give me any advice that you can. thanks for all of your help. Justin
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top