Team Chevelle banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Howdy all, I'm new to the forum but I have a feel for how they work.

I have got a 66 396 SS and I'm trying to get it in A-1 condition. I'm attempting to get the horns working today and so far all I've gotten is the relay to click. My question is, Can I test my horns by taking a wire from the positive post of the battery and go directly to the horn and then should it honk? I don't mind having to get new horns but I need to know if they are really bad or what else could it be. As I said the relay clicks and I've taken the cover of it off and I can see it engage but no honk. And then I tooh a wire directly from the positive post to the connector on the horn. Should it have honked?

thanks
 

·
Registered
Joined
·
7,758 Posts
Yes, that should have made it honk. You also might want to try touching the horn directly to the battery. Unscrew the horn and shine up the area where the mounting bolt hole is located. Touch that shined up area directly to battery (-). Now connect the horn wire directly to battery (+). and see if the horn works.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
thanks a little tapping and beating got the high note one working and the low note was working until I got the bright idea to wash it out with water. It just so much grit going out after i sprayed them with w-d 40 that i figured it might need flushed and the high note still works but the low note quit. one horn is better than no horn. thanks for the reply.

hg
 
1 - 4 of 4 Posts
Top