Team Chevelle banner
1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I recently installed an HI-6 fireball from crane cams...........but after I wired it in and got the car running.........when I turned the key off at the ignition the engine kept on running.........I also have a push button starter installed.........could this be some of the problem??????
 

·
Registered
Joined
·
7,758 Posts
Read through Crane's instruction manual on that unit. They refer to adding the diode into the circuit, same as MSD's instructions. Think the paragraph about engine run-on is towards the bottom of the instructions but I only quickly viewed it on-screen. They send you a small diode in the package? No, your remote starter switch doesn't hurt. http://www.cranecams.com/instructions/electronics.htm
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
see that's my problem.............I bought the unit new from my friend in cali........and he didn't send me the instructions..........or that diode......
 

·
Registered
Joined
·
7,758 Posts
Yeah, you really can't trust those guys in California. I only glanced at the Crane instructions. (Trying to actually work at the same time). I don't know how detailed they were. They diode goes in the alternator brown line. You can get a diode from Radio Shack. MSD's instructions are fairly clear if Crane's are not. The instructions for the 6L are here if I type the right address. www.msdignition.com
 

·
Registered
Joined
·
17 Posts
Go to the crane cams website and you can get the installation instructions from there.
 

·
Registered
Joined
·
418 Posts
Are you using an electric fan? If so, disconnect the power to it and see if the engine will shut off then. Depending on how the fan is wired into your electrical system, it's spinning can act as a generator and keep your ignition system powered. I know it sounds crazy, but I had it proved to me on a friends car that we put an MSD ignition in. We finally read the directions (I hate having to do that!)and installed the diode. The engine shut off as it should after that.

------------------
It’s a BIGger BLOCK!
 

·
Registered
Joined
·
35 Posts
I am using the Crane HI-6 on my 69 Z/28, and did not need to use a diode, which BTW does NOT come with the Crane unit. And your'e right about the fan problem, seen it many time on street rod projects, a diode will cure that.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
well the diode sounds like my problem......but I wont find out until I get my new heads on.......and I had to go to the msd site to figure out how to wire the fireball in...........or get a good Idea........I'm thinking about just getting an msd and that would probably solve all my problems...............
 
1 - 8 of 8 Posts
Top