Team Chevelle banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
485 Posts
Discussion Starter #1
The rear of my 70 chevelle is 5/8 inch lower on the drivers side. I know its not much, but it is noticeable and driving me crazy. I have put in new body mounts, and the rear springs check out okay. I put the front on stands (both side equal height) and the rear still leans. BENT FRAME???? I am current rebuiling the front suspension, so when I get it back together, maybe that will help. Any other suggestion on how to fix the lean???
 

·
Registered
Joined
·
172 Posts
How about a 5/8 shim on the spring pad? How did you test the rear springs? By measuring them side by side? Were both the same length? It is possible for the springs to be equal in height but, one may have lost a little tension(is that called spring rate?) anyway, one spring may not have the same tension as the other allowing some sag.I know with valve springs there is a machine that test each one to make sure that they're all the same tension.Does anyone know if they have a tester like this for back coil springs? Maybe contact a spring shop. Hope this helps a little.

------------------

–Joe–
"67 Malibu"
 

·
Registered
Joined
·
72 Posts
I have the same problem on my 69. I replaced the rear springs. No luck there. My body mounts look OK too. Front springs were replaced by previous owner. It too is driving me crazy. I put in rear air bags and pumped up drivers side more than pass. side, basically just a band aid, the problem is still there somewhere. Let me know if you find the problem.
 

·
Registered
Joined
·
44 Posts
To find out if it is the spring you could try switching them, since rear springs are really easy to install. My car also leans about 1/4" to the drivers side and it's really annoying!!!
 

·
Registered
Joined
·
10 Posts
i have the same problem with my 72 i have been told it is my front drives side spring if it is weak it lets the passenger side rear raise up higher try lifting with your hands the drivers front a little and see if it levels out it works for mine.

good luck guys
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top