Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
The last couple of days when it has been cool at night I've had some weird experiences with my headlights and interior dash lights. Yesterday, my headlights worked but my dash lights didn't. This morning the situation was reversed. At noon when things have warmed up, my headlights work again, but my dash lights don't. I have aftermarket gauges in their own panel, The guages work, it is just the light circuit. They are connected to the lamp jumper on the fuse panel. The fuses appear to be good.
 

·
Registered
Joined
·
777 Posts
Sounds like a faulty headlight switch.
Take a good look at it.
Fred
 

·
Registered
Joined
·
7,762 Posts
Fred might be right. A couple of other ideas since I was off-line typing this up.
Helps a touch if you mention what year. There are some differences between the cars. A couple of thoughts in the meantime.
1, These are two different circuits.
2, The dash lights and the outside running (tail) lights are powered by the same wire (orange) to the headlight switch. Are you having any problems with the running lights?
3, Have you looked at the small ground wire from battery (-) to the right inside fender? Everything clean and tight? This is the ground for these two items.
4, The instrument (dash) light fuse is the short fuse located in the center bottom of the fuse panel. Checked that? Are the fuse clips ok or are they rusted up? Do you have 12 volts on each side of the fuse?
 
1 - 3 of 3 Posts
Top