Team Chevelle banner
1 - 3 of 3 Posts

·
Premium Member
Joined
·
276 Posts
Discussion Starter · #1 ·
Are the headlight switches different between a 69, 70, 71, and 72 A body (chevelle or monte carlo etc) ?

upon final shakedown my lights aren't working correctly. pull the switch out and parking lamps work, dome light and console work, guages work, no problem. Pull the switch all the way out and headlights go on, but everything else dies (guages go dark etc)

checked all grounds we can find, all appear to be good. so it's either the switch or the gauge cluster we think. we also think the switch that was in there might be from a 69 or 71/72 car and isn't right? (I thought they were all the same)

ordered a new switch for a 70, hopefully this will solve the problem. had to take the dash pad off again though to get to it.

why would GM make 4 different switches from 69-72? weird. opinions? thanks
 

·
Premium Member
Joined
·
435 Posts
I replaced my switch because af a similar problem. AutoZone has it as a stock item for $11.99. Still had the problem afterwards so I cut a piece of wire and grounded the gauges to the dash mounting bracket (two places) and the problem went away.
 

·
Premium Member
Joined
·
276 Posts
Discussion Starter · #3 ·
does anybody have the wiring setup on the grounds from the guage cluster? there are already 3 of these plus another ground from the switch itself. All grounds were checked and appear to be good (unless were checking them wrong?)

where did you add another 2 grounds from? any pictures? not from the circuit board, but the plastic case??

new switch is going in today. we'll see if that helps. anybody else? this the LAST thing that is keeping my car from being finished and on the road :(
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top