Chevelles.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i have some sort of short in my 67'. it only happens when i turn the right turn signaler on. there is a loud popping noise, then the dash lights go out and so do my tail lights. i have to replace the dash fuse after that. i have jiggled some wires around to clean those up, and cleaned up the wires by the right tun signal. it doesnt happen nearly as often now, but it still happens.
 

·
Premium Member
Joined
·
4,477 Posts
Originally posted by 6chvlmalbu7:
i have some sort of short in my 67'. it only happens when i turn the right turn signaler on. there is a loud popping noise, then the dash lights go out and so do my tail lights. i have to replace the dash fuse after that. i have jiggled some wires around to clean those up, and cleaned up the wires by the right tun signal. it doesnt happen nearly as often now, but it still happens.
Hmmmm, that's interesting. You ONLY have to replace the "dash fuse"??? By right, if you loose your tail lights too, you would have to replace the "TAIL LPS" (tail lamps) fuse as well. The dash fuse taps power from the tail lamp fuse. If the tail lamps fuse blows, you automatically loose all of your dash illumination regardless if the dash fuse is blown or not. Has someone altered the wiring?? Any splices or anything look out of place under the dash to begin with?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Im sorry i meant to say Tail lamp fuse.
 
1 - 3 of 3 Posts
Top