Chevelles.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
I have a 68 malibu with a new 350 goodwrench engine that was installed in july. well my concern is when im at the stop light, the gen light isnt fully on but its dim and its making me think its going to shut off. it never does and the idle doesnt change but its just makes me worry. any suggestions from people who have had the same problem???by the way its an idiot light...thanks in advance
 

·
Registered
Joined
·
65 Posts
Discussion Starter #2
forgot to add it goes away once i press the gas and start going
 

·
Premium Member
Joined
·
9,801 Posts
Maybe you should check the voltage at idle and see if it is charging. Then you need to find out if it is a regulator problem or an alternator problem.
 

·
Premium Member
Joined
·
6,741 Posts
Originally posted by JWagner:
Maybe you should check the voltage at idle and see if it is charging. Then you need to find out if it is a regulator problem or an alternator problem.
If it is charging ok then check the grounds on rad support. Mine glowed at idle after re-assembly, new rad support. Once I got the grounds fixed it went away.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #5
thanx whats a rad support? thinking radiator support but dont know where to look for wires
 

·
Registered
Joined
·
1,922 Posts
Rad support is the radiator support.

Just start following the hot wires (and ground) wires from the battery.

Check for broken wires, corroded connectors, etc. The regulator is on the drivers side radiator support. Looks like a square box about 4 " x 4".

Usually the regulator connector or the wires that are on to the common hot at the regulator need looked at. <ake surew none are corroded or burnt or broke.

Do you have a volt-resistance meter? A cheap one from a hardware store will help.
 
1 - 7 of 7 Posts
Top