Team Chevelle banner
1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
For the last 3 months I have had this annoying buzzing when I turn on the headlights. As the car goes faster the buzzing goes away the headlights get stronger but the GEN light continues to stay on. I have changed the following: Alternator, regulator, horn relay and the Battery cable. Battery has been tested and that is ok. What can I possibly check next to figure out this problem?
 

·
Registered
Joined
·
275 Posts
Any idea the location of the buzz? My guess, on this limited informaion, is you have a ground issue. Check and make sure you have a nice OEM style braded copper strap ground for BODY steel to ENGINE steel. Also use a volt meter and see what kind of ground your headlights have. Aslo check the battery ground

------------------
Paul Schultz in Lake Worth FL
1970 SS 454 LS-5/M40
2000 Horton [email protected] in 1/4 mile dragster Oh-yeaa
 

·
Registered
Joined
·
7,758 Posts
As Paul say, describe the buzzing noise a little better. Maybe it can be isolated. Disagree on the ground straps. Don't make the engine run. If you have a good body ground, ground straps don't help much.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #4 ·
Well its a buzz similar to that of the door open. I know the sound is coming from the horn relay.
 

·
Registered
Joined
·
7,758 Posts
*Scratches head*
1, Buzz sound
2, Sounds like horn relay
3, Changes pitch
4, Gen light on
You sure it can't be the voltage regulator making the noise? Regulators can make a buzz sound. Can you feel the regulator vibrating at idle? Do you have a ground wire from battery (-) to the right inside fender? Is the regulator grounded?
 
1 - 6 of 6 Posts
Top