Chevelles.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
It occurred to me that I need to clean up some of the contacts on my `72. I was quite disturbed to find that one of the clips for the instrument panel fuse "section" is very loose. I haven't really examined any of the other clips, but I don't know what to do. Are the individual clips replaceable? Or do I have to look for a new fuse box? How do I get the bulkhead connectors out of the back of the box? Are the clips pushed in? Riveted? Thanks for all of your help!
 

·
Registered
Joined
·
7,762 Posts
If the clip is just loose in the plastic, I'd bond it down with a couple of drops of epoxy. Won't move at all once the fuse is installed.
Yes clips are available as are fuse blocks. The bulkhead connectors come apart by removing the screw between them under the hood.
A good deal of work versus a couple of drops of JB Weld.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
Thanks! It appears that the clip is loose in the plastic. Where can I get more of them? Are they available at any auto parts store? I'd like to keep the original fuse box, which looks possible.
 

·
Registered
Joined
·
7,762 Posts
I'll try and dig through my stuff at home later and find a net source for the clips.
 

·
Registered
Joined
·
1,763 Posts
i dont want to challenge john at all
learned a lot off of many of his postings
just wanted to add
these clips are nomally loose when no fuse is in place
as long as they are not pushing out of fuse bock this seems normal
 
1 - 7 of 7 Posts
Top