Chevelles.com banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
I have a 72 velle factory tach and have problems gettint the tach to wok. I have a comp9000 with a msd coil and it only works off and onn. I did try the diadode in line to the - side of the coil and also when I used to have a high fire box mallory sold me some little thing that looks like a minature coil just alot of windings and a line in and out. I have tried all these things nothing seems to work I even took the tach out of the dash to ensure I didnt have a ground problem and tried hooking it up under the hood. It will work for a few seconds to 30 seconds then quit the work then not. If I hook it up to a hei it works fine. Any help would be great

thanks
 

·
Registered
Joined
·
105 Posts
Since you already tried the diodes this might not be much help. Have you contacted the manufacturer of the Comp9000. What does MSD say? Before I installed a pertronix ignitor I emailed Retro Rockets and asked what that would do to my tach's accuracy.
Carl from Retro Rockets replied:
"The Ignitor will work with most tach setups without any additional circuitry. With some tachs the electrical input must be conditioned to work properly. This is easily done by wiring in two diodes in series into the tach circuit. These diodes are inexpensive and available at Radio Shack... It is not complicated at all."
The fix used two Radio Shack 400A 3V diodes in series. Part number 276-1144. The bands on the diodes point to the tach lead and the other connection is to negative coil terminal. If you want the picture, email me and I'll send it to you.
When you get it working please post the solution. I'll bet we aren't the only ones with these problems.



------------------
1967 Malibu
1967 Impala SS396 Conv.
"Let me show you how the guards used to do it."
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top