Chevelles.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
I started up the 502 tonight but it kept running even after turning the key off. The wiring harness is new from m & d. the engine is a deluxe zz502 with a one wire alternator and hei ignition(stock). Also the headlights come on when the key is in the ON postion, but they are dim. they become much brighter if I turn the headlight switch on. Also they headlights dont work at all if they key switch is in the OFF postion. and yes the ignition switch is new. any ideas before I get back on it in 10 hours? thanks
 

·
Registered
Joined
·
7,762 Posts
Where did you connect the wire for the HEI? Without firing the engine, disconnect the HEI B+ wire out of the cap. There should be 0 volts to ground with the key off and 12 volts to ground with the key on.
 

·
Premium Member
Joined
·
142 Posts
You have a ground problem somewhere and the current is having to go through your lighting circuit to get back to the battery.

You have a 1 wire alt no no feedback from the regulator, go ahead and unplug it though.

Check coil voltage as mentioned, should be 12ga ign feed.
 

·
Registered
Joined
·
4 Posts
with a one wire alternator you will need to put a one way resistor at the voltage regulator. It should have come with the alternator.
 

·
Registered
Joined
·
2,922 Posts
Originally posted by Paula s 71:
with a one wire alternator you will need to put a one way resistor at the voltage regulator. It should have come with the alternator.
That's a new one on me. I've bought a couple of one-wire alternators from Powermaster, and neither one came with a "one way resistor" (diode?), or anything else. Just the alternator and instructions. You may be thinking of the diode that comes with an MSD ignition.
 
1 - 5 of 5 Posts
Top