Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I have a 72' Chevelle with a 307 in it. The car had been running fine until recently when the generator light came on. The car ran fine with no problems for almost two weeks, then one night it wouldnt start. I was able to start it and make it home, however after shutting the car off it made no attempt to start. If i let it sit for about a day I was able to get it to start. I thought this might be an alternator problem since the alternator was not putting out many volts. I replaced the alternator, and the problem has not gotten any better, and the engine now makes a squeeling noise when you push on the accelerator. The generator light is still on and I have no idea what is causing this problem.
 

·
Premium Member
Joined
·
1,404 Posts
Danlg65,

It sounds a though your alt/gen was definitly bad. The car was continuing to run off the battery alone until it just got too week from not being recharged. Somrtimes aftermsitting for a while they'll build up just enough power for one more start.
Replacing the alt/gen should have corrected most of the problem however did you completely recharge your battery? Where did you purchase the replacement from? Was it a new unit or a rebuilt unit? Some rebuilds from the chain auto part stores are not the greatest and you could have another bad one. The squeel could be improper adjustment of the gen/alt belt tension.
I would start over again, remove the gen/alt and have it tested for proper output. At the same time put a battery charger on your battery and get it up to full charge. After reinstalling the new generator make sure your belt tension is correct about 1/4 to 1/2 inch deflection of the belt when pushing in on the longer side of the belt between pullys. Also if you have a outside voltage regulator make sure it is also working properly.

Good luck

------------------
FastSS396Man
Brian

Fastss396, Fastss396,Fastss396,
Fastss396,Fastss396,Fastss396,Fastss396,Fastss396,Fastss396,Fastss396
69' SS396 Chevelle
L78 396/375hp
M-21 Close Ratio
Cortez Silver
10 year Resto
It's brand new again!
02' Harley FatBoy, Diamond Ice Pearl and lots of chrome!
ACES# 3466
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
I have checked all of the wiring and it all looks good, so i went and bought a new voltage regulator, but i am having trouble locating where it is. Can anybody tell me where it is located, and how i would go about replacing it
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Never Mind, i replaced the voltage generator. I am not sure if the problem is fixed, but the generator light is off, so thats a good sign.
 
1 - 4 of 4 Posts
Top