Team Chevelle banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 1970 Chevelle SS 454. The Dashboard lights are extremly dark or don't work. I have replaced the bulbs, the tach, clock and speedometer, checked the reostat on the light switch, the strip for connectivity and ground to insure a good ground. All are correct or work.

What else can I do?

Thanks,
Brooksy
 

·
Premium Member
Joined
·
1,109 Posts
in my '72 they began to flicker, finally went dark. i replaced the light switch and all is well. how did you check the reostat?
 

·
Registered
Joined
·
1,747 Posts
Did you verify that the lights are working? Just replacing the bulbs doesn't gaurantee they will light. The socket could be dirty or bad and you could have a broken trace on the circuit board. The other option (expensive) is to replace the bulbs with led's, most auto stores have drop in led raplacements for the 194 bulb, they are brighter and use less energy.
 

·
Premium Member
Joined
·
1,006 Posts
I had the same problem with my 70 SS. I put new bulbs in and some still did not work. Take the sockets out and clean the contacts where the bulbs slide in, that did the trick for mine. You can put the bulb back in and check for continuity with a meter before you put the socket back in the dash to make sure you got it clean enough. A point file works great cause it gets in there really easy. Let us know how it works out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Hi All,

Thank you very much for your suggestions. I will try them this weekend.

Take Care,
Brooksy
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top