Chevelles.com banner

1 - 10 of 10 Posts

·
Registered
Joined
·
517 Posts
Discussion Starter #1
This just started hapening on a regular basis now.Last year it did this once or twice,but now it seems that everytime I go to turn off the car key to off pos. the GEN light comes on so I have to pull the coil wire to sut it down.
PS DONT wear a belt buckle and lean into the car when you do this :eek: .Any way ,I installed a kill switch,that took care of itBUT.could some one tell me what's going on so I can fix this the right way.The reg,ign switch alt are ALL new.
Thanx for any help.........Steev
 

·
Registered
Joined
·
4,432 Posts
If you have MSD ignition you probably need a diode in the #3 regulator wire.
 

·
Registered
Joined
·
517 Posts
Discussion Starter #4
Trop, did that once.......ONCE :D

Jon,I do have the MSD box.Would toy happen to know the value of the diod? and which way to install it? Thanx much........Steeev
 

·
Registered
Joined
·
196 Posts
Oh ya did the coil trick and battery + last


On mine the ignition switch was bad.
 

·
Registered
Joined
·
32 Posts
I had similar problems with my 69 running on, until finally died for good. My buddy reccomended sending back to MSD for rebuilding. I had a few things wrong (blown/bad) MSD will fix it as long as your box isn't older than five years. Recieved it a few weeks later collect in the mail for the grand total of 32 bucks!!!! They will have my business from now on!!
 

·
Registered
Joined
·
85 Posts
When all else fails, "CHANGE YOUR IGNTION SWITCH." There cheap at local parts store. They get wore out and most folks change everything else. then they chg Ign swt. Like me!!


Remember the ol' saying
"KISS"
Keep It Simple Stupid!!
I have a hard time remembering that....hahahaha
 

·
Registered
Joined
·
241 Posts
I agree with 70ss427. Being a retired locksmith, I had a box full of used ign sw.s I tested them by hooking them up to old head lights for load. 16 of the 24 had bad conections. this can be caused by hot wiring the ign sw.
 

·
Registered
Joined
·
218 Posts
Here is something I ran into. Any chance that you are using and electric cooling fan? I had been using one with a Factory GM HEI distributor and oddly if the fan motor rotated in the reverse direction of normal "cooling" rotation it would back feed power and with the key in the off position the car was still running. Also ran into a problem where a bad regulator was casuing the GEN light to stay lit although dimly with the key off.
 
1 - 10 of 10 Posts
Top