Team Chevelle banner
1 - 6 of 6 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter · #1 ·
so the car runs fine, but when I put it in gear the motors rpms drop so low its about to die. I was wondering what would cause this. Its a 350 with xe274 cam, weiand stealth intake, and a speed demon 650 vac secondary carb
 

·
Premium Member
Joined
·
11,203 Posts
Disconnect the Vacuum adv, plug the carb vacuum inlet for the VA
Ensure you have 16-18 degs initial timing
Idle the engine to 800
set the idle mix on each side to best idle speed
Set the engine idle down to 700,
repeat with the idle mix screws.....
set idle back to 700
reset idle mix screws
set idle back to 700

I believe the XE274, the manufacturer suggests a higher than stock stall on the converter.....

BTW, at idle in neutral, you should have 14" vacuum or there about.....
What reading are you getting?
Ahhhhhhh, have not used a vacuum gauge yet....good device to have.....
 

·
Premium Member
Joined
·
9,919 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter · #5 ·
Disconnect the Vacuum adv, plug the carb vacuum inlet for the VA
Ensure you have 16-18 degs initial timing
Idle the engine to 800
set the idle mix on each side to best idle speed
Set the engine idle down to 700,
repeat with the idle mix screws.....
set idle back to 700
reset idle mix screws
set idle back to 700

I believe the XE274, the manufacturer suggests a higher than stock stall on the converter.....

BTW, at idle in neutral, you should have 14" vacuum or there about.....
What reading are you getting?
Ahhhhhhh, have not used a vacuum gauge yet....good device to have.....
i'm getting a steady 10" vacuum at idle
 

·
Premium Member
Joined
·
11,203 Posts
OK, vacuum gauge in hand...great!

10" from a XE274.....sounds really low...

FYI, my 427 RatVette has a pretty healthy cam 235/235* dur @ .050" .542/.542" lift, 111 LSA, 10.2:1, 781 ovals and it idles about 13" at 800 in neutral. My 350-powered 70 Elky has some sorta moderate perf cam in there...9.7:1 CR, idles at 14"

Increase you initial timing.....this will help the low vacuum and get your throttle blades centered on your idle transfer slot on your carb.... If this does not work....

Sounds to me like a SERIOUS vacuum leak. Get some carb spray and start shooting at the carb gasket base, throttle shafts, sides of intake.....
 
1 - 6 of 6 Posts
Top