Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
406 Posts
Discussion Starter · #1 ·
When I have my radio on with the amps going I am getting an annoying hum or buz through my speakers. Can anyone help?
 

·
Registered
Joined
·
32 Posts
Im no electrican by any means but I do read alot of car craft, and every time that subject is brought up they always ask about the plug wires whether they are shielded which might be causing the buzzing in the speakers. Does the buzzing speed up when the car is accelerated if it does I bet that might be the problem. I also have noticed that they sell noise suppresors which go inline to the radio circuit to keep out the same noise. Hope this helps!

Natalie's Dad
and his 69 chevelle
 

·
Registered
Joined
·
168 Posts
Do you have an electric fuel pump? It could be causing this problem. I know cause there is a technical service bulletin on my 94 sable that has the problem. If it is the prob, you'll have to install a flter on the elect connection going to the pump. Just a thought.
 

·
Registered
Joined
·
406 Posts
Discussion Starter · #4 ·
No Electrical fuel pump. Still guessing?
 

·
Registered
Joined
·
948 Posts
Alternator whine? Does it increase as RPMs increase?

If so, that may be what it is. It's been a while, but I think it may help to have the amp wires and speaker wires far apart.

Maybe a site that has auto stereo wiring tips would be able to help.
 
1 - 7 of 7 Posts
Top