Team Chevelle banner
1 - 11 of 11 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
I notice the left/driver side brake light was not working when pressing on the brake. Thought it would be a simple light bulb replacement. tested the bulb and it still works so its not the bulb. its electrical. I checked the wires seems okay. When the head lights are turned on it lights up but just doesnt brighten up when you brake.

Where should I look or what can I do to find or fix the problem. I dont want to mess it up more since I dont really know where to start.
could it be the fuses?!?!

the other side brake light works perfect. and they were both working fine last time I checke until today when I took the car out for a wash and ride.
(72 chevelle) thank you in advance!!!
 

·
Gold Founding Member
Joined
·
64,430 Posts
If the turn signal and taillight work on that side, I would say the problem is most likely in the turn signal switch.

The turn signal switch turns off the brake light when it turns on the signal so it's probably not turning it back on when the lever is returned to center.

A problem in the stop light switch would effect both sides.
 

·
Premium Member
Joined
·
1,394 Posts
I would clean the bulb receptacle for good measure as well.
 

·
Premium Member
Joined
·
2,238 Posts
Dirty contacts in the indicator and or hazzard switch, very common, spray a liberal amount of contact cleaner into the switch where the lever comes out. If that dosen't do it ? pull the wheel and dust cover off (don't loose the horn spring etc.) and spray more directly on to the brass contacts inside, you should also use some spray lube afterwards, good luck
Dave
 

·
Gold Founding Member
Joined
·
64,430 Posts
Dirty contacts in the indicator and or hazzard switch, very common, spray a liberal amount of contact cleaner into the switch where the lever comes out. If that dosen't do it ? pull the wheel and dust cover off (don't loose the horn spring etc.) and spray more directly on to the brass contacts inside, you should also use some spray lube afterwards, good luck
Dave
Does the brake light circuit go through the "hazzard switch" also?

:confused:
 

·
Registered
Joined
·
657 Posts
Check the ground, that was my problem. Pull the socket out and attach a good ground wire on it, if the bulb lights clean the socket and opening with emerycloth... better yet if that's the problem do all your lightsockets.
 
1 - 11 of 11 Posts
Top