Team Chevelle banner
1 - 7 of 7 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
I just installed some new LED lights in my taillights on a 67 Chevelle. After they were installed, everything worked, tailights, turn signals, and brake lights. The problem is if I push the brake and turn my right turn signal on, the brake lights quit working. If I turn my left signal on the brake lights still work. What would cause this. I did a search and found one entry that suggested dirty contacts on the turn signal switch. Is there anything else that would cause this. How do you clean the contacts. Do you have to pull the steering wheel, or is there another way to clean it. I don't know if this was like this before the LED installation because I never checked it, but it could have been.
2nd question: Is this normal. When I turn on my headlights, my front parking lights go out. The front parking lights only work by themselves when I pull the switch one click. Pull it out to turn the headlights on and they go out. Is that the way they work. I always thought they should still be lit headlights or not. Does anyone know. The turn signals work the way they're supposed to. Thanks
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #4 ·
Okay guys, just for the heck of it, I switched back to the old assembly removing the LED set up. I get the same problem. Taillights, brake lights, turn signals all work separately. Step on the brake, turn my left signal on, works fine and brake light works fine. Step on the brake, turn my right signal on, and the brake lights go out. I pulled the steering wheel, cleaned the signal contacts. Still does the same thing. What else could it be. I'm lost from here. All connections are good, ground etc. I don't know where else to go from here. Please help!!!!
 

·
Premium Member
Joined
·
1,493 Posts
did you check the number on the bulb. you could have the wrong type bulb. Contacts on bulb may not line up. Hope this help.
By the way, that year chevelle you have, the parking light does go out when you pull to the second click for the headlights.
I'm not to sure but 68 on up the parking light stays on all the time.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #6 ·
did you check the number on the bulb. you could have the wrong type bulb. Contacts on bulb may not line up. Hope this help.
By the way, that year chevelle you have, the parking light does go out when you pull to the second click for the headlights.
I'm not to sure but 68 on up the parking light stays on all the time.
Yeah, they are the right bulbs. I swithched them with each other for the heck of it and still the same. Hit the brake, right turn signal on, no brake light. Left turn signal on, brake lights work okay.?????? I'm not sure what else to do. Replace the whole turn signal switch. Not sure what kind of a job that is. It don't look to easy. I don't know.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top