Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Premium Member
Joined
·
589 Posts
Discussion Starter · #1 ·
The blower motor on my 70 quit working, but I don't think it's really the blower that's the problem. Not running in any positions and the ac compressor doesn't click on when I slide the selector to the ac position. I can hear the vacuum selector working under the dash when I move the selector knob through the ac, heat and vent positions. What do you guys think, bad head unit in the dash? Loose connection? I know I'm gonna have to get into it, just looking for clues. Thanks, Narti.

------------------
Nick P.
Team Chevelle Gold #36
http://home.attbi.com/~nicpal www.chevelles.com/showroom/Nick's1970ChevelleSS396.jpg

[This message has been edited by Narti (edited 09-03-2002).]
 

·
Registered
Joined
·
1,273 Posts
Chances are its the switch on the A/C controller. Pull your dash pad off and you should be able to get down in there to check for power. Oh yea youll have pull your cntr outlet duct.
Narti Do you also hang out at the SS Impala forum?

------------------
Philip Mullaly
72 TPI El Camino
You can never fix a Ford,You can only work on them alot.
70 442
The Z-meano
Cowl induction injection
 

·
Registered
Joined
·
7,762 Posts
Philip may have nailed it but before you take the pad off:
Look for power on the hi-blow relay under the hood. Anything on the purple wire to the blower motor, the orange hi speed power, and any of the others as you flip around the switch? (key on)
 
1 - 4 of 4 Posts
Top