Chevelles.com banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Yesterday my turn signals were working fine, and then when I started 'er up this morning they just don't blink any more. When I try to use them they turn on and just stay on, solid instead of flashing. I checked all the bulbs and they seem to be fine, and it seems strange that it happened to both sides at once; do you think it's a short, or a fuse or ... a voodoo curse? Thanks in advance for the help. Every time I think I learn something about these cars, three more things happen to confuse me even more!
 

·
Registered
Joined
·
336 Posts
My guess is that your flasher has gone bye bye. They cost something like 2 bucks at auto zone. Get a nice heavy duty flasher and one for the hazzards too

------------------
Frank W
Arlington MA
74 Laguna S3 !! ( No motor yet)
73 Malibu Coupe Mighty 305 Power
hometown.aol.com/folingo/
 

·
Registered
Joined
·
18 Posts
The turn signal flasher is hanging under the dash near the steering column, the one in the fuse box is for the hazzards.
 

·
Premium Member
Joined
·
4,477 Posts
You didn't state what year your car was, but on my '70 the actual correct factory place for the blinker "can" is by the steering column, there is a spring type clamp that holds the can in place on one of the dash supports.

Also, you might want to look into purchasing a "2 lamp flasher", instead of the regular heavy duty ones.

I just bought a WAGNER 224 flasher, it works with 2 lamp cars (like chevelles)--if one turnsignal bulb burns out, it gives you an early warning as it won't cause the remaining light to blink any more giving you notice to check your lights! Pretty clever!

Cheap insurance too!

Joe

 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Sorry, I should have added that I'm driving a '72 Malibu. Thanks for the help, sounds like it shouldn't be a big problem.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top