Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter · #1 ·
I've got the CRANE XR700 Points conversion Box with optical trigger into my '67 Dizzy.

It says if the box runs hot to the touch after 15 min, it needs a 1.2-1.9ohm ballast resistor.

Well when I first got the motor runnin', it didn't feel hot so I figured everything was fine.

Ran great with the Jacobs Ultra Coil too.

Well the other day I'd get this weird jerk for just a split second, or sometimes a jerk jerk....

Watched the tach jump from 2000rpm to 0, back to 2000....

It's not fuel related and seems like the ignition spark just upright cut out.

Friend told me sometimes bad tachs can do it, and to check the Tach to coil wire for shorts.

Decided to put my hand on the crane box again while running (I could never get it to cut out while at an idle)... and now the box was so hot it burned my hand.

Put the ballast resistor on that it called for and it runs fine now EXCEPT;

It's considerably less powerful, so much that I can feel it. Friend told me that the Jacobs coil isn't getting the 12v it needs for it's variable spark thing.

I don't like my options.... (Mallory Magnetic Dizzy, MSD box, live with it).....

I was wondering, the ballast is installed on the 12v + wire before it reaches everything. What if I made the 12v wire go to the coil as it was before, and the wire going from coil + to crane box have the ballast?

My friend seemed to think it wouldn't change anything because the box grounds out the coil, and would be too much load or something like that.

I don't see how grounding it with or without ballast would change anything. The only thing I see changing is that the coil isn't getting 12 volts now.

Any ideas with this wiring? I'd rather not fry my box, nor buy a new dizzy, and I'm not impressed with the MSD box in my other vehicles.

Thanks for the help!
-Paul
 

·
Registered
Joined
·
505 Posts
Discussion Starter · #2 ·
Well today I tried the resistor between Crane box and COIL + and it does it's cut out thing again.

Maybe it's the coil?
 
1 - 2 of 2 Posts
Top