Team Chevelle banner
1 - 5 of 5 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
I just installed the autometer pedestal mount tach#5899. I used the same wiring that my prev tach used, but now I'm not getting power at the tach. The old tach worked. The gauge light works, but when I turn the key, the light goes out. The car has been sitting for awhile(winter). Does this tach need a full 12 volts for it to operate. The battery was at 10-11 volts when I checked and the old tach worked fine. All other gauges work, just the tach is giving me problems.
 

·
Premium Member
Joined
·
6,740 Posts
First, nice car! Where was that first pic taken, Belle Isle maybe? Kind of looks like it was. I see you changed wheels, which ones you running now?
You say the light works, when you turn the dash lights on? Then it goes out when you turn the key, turn the key to on? I assume you started it and the tach does not work, maybe not, maybe you're just talking about the light. If you did start it the voltage should come up from the 10-11. Not that I have an answer but a little info may be needed.
 

·
Registered
Joined
·
196 Posts
Discussion Starter · #3 ·
Thanks. That pic was taken somewhere in Southfield when I first got it 6 years ago. Cannot remember where though. I was refering to the dash lights. Only the light for the tach goes out when I turn the key to start the car. I'm running the vintage wheelworks 17" wheels v45 I think. 17x8 fronts 17x9.5 rears. I went back out and tried again and now the tach has power. Might not have had a good ground as the dash is still out of car.
 

·
Premium Member
Joined
·
6,740 Posts
Originally posted by TINMAN:
Thanks. That pic was taken somewhere in Southfield when I first got it 6 years ago. Cannot remember where though. I was refering to the dash lights. Only the light for the tach goes out when I turn the key to start the car. I'm running the vintage wheelworks 17" wheels v45 I think. 17x8 fronts 17x9.5 rears. I think I got it. I went back out and tried again and now it the tach has power. Might not have had a good ground as the dash is still out of car.
Good deal on the tach. As far as the pic where is there a lake like that in Southfield? I grew up on the eastside and it just reminded me of Belle Isle. Now that I look at it again it does look more like a small lake than the river. Still it's a nice pic.
 
1 - 5 of 5 Posts
Top