Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part May's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
5,069 Posts
Discussion Starter · #1 ·
On my way to work today my Pioneer cd player (not even a year old) killed power to all 4 speakers, only the 2 subs in the trunk are working.

Is this some kind of internal feature that is trying to say I have a speaker wire grounding out?

I want to fix this after work but I don't know where to start since I'm assuming a blown fuse would prevent the unit from getting power
 

·
Registered
Joined
·
70 Posts
Are you running the 4 speakers with the radio or an amp? Are you using a EQ or an electronic crossover? If you are just using the radio power check your connections. I think if a fuse had blown you would not have power at all to the radio. If the connections are good you might have fried amp in the radio. Had a radio do the same thing to me, it was almost the same money to buy a new one. Hope this helps.
 

·
Registered
Joined
·
5,069 Posts
Discussion Starter · #3 ·
well last night after work i wasted 4 hours playing with desktop dyno

tonight i spent 4 hours trying to fix the radio, temp guage, and high beam indicator...no luck with any of it

looks like i get to waste some of my new suspension money on a new cd player and waste a weekend i was going camping pulling the gauge cluster to clean the tach out, replace a speedo, and beat the hell out of the temp guage for driving me nuts
 
1 - 5 of 5 Posts
Top