Chevelles.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,033 Posts
Discussion Starter #1
I just had my alternator rebuilt, and it seems to be working fine, but the light in the dash is lit constantly (although dimly lit) Do i really have a charging problem, or is there an easy way to make the light stop coming on, aside from removing the bulb...I seem to recall another car i had years ago with the same problem and if you disconnected the battery and reconnected it, the light went out... tried that and it didnt work... unplugged the wires from the back, still didnt work... wondering if maybe the 'rebuild' wasnt so good...the light WASN'T on beforehand by the way, but the bearings were making noise. Any ideas?
 

·
Registered
Joined
·
7,762 Posts
How old is the regulator? Without taking a few measurements around the regulator output a guess is that it's acting up.
 

·
Premium Member
Joined
·
2,223 Posts
What alternator do you have and is the light off with the ignition off and on, bright with the ignition on, engine not running?
 

·
Registered
Joined
·
1,033 Posts
Discussion Starter #4
Its a factory 837. (37 Amp) I just checked, and the light comes on dimly when you turn on the key, same as after the car is running...the light goes off when you turn the key off. Any other ideas?
 

·
Registered
Joined
·
1,033 Posts
Discussion Starter #6
Should the alternator light come on on the dash when you turn the key to the on position without starting the car? I still havent figured the problem out, but i think its a bad alternator, as my battery was dead today... the alt. light stays on the entire time i am driving, what makes this light come on exactly? Sorry to sound like an idiot, but i really don't have much knowledge of this electrical stuff. I swapped a different regulator and it still acts the same, with the alternator light staying on all the time... i guess that means the alternator is not charging? Can the alt be tested on the car, or do i need to take it off and take it to an auto parts store for testing?
 

·
Registered
Joined
·
7,762 Posts
The GEN light does come on when you first turn the key on. This is to verify that the bulb is good. It goes out after the engine starts. Follow the instructions Peter wrote in the link I attached above and post back the results.
 
1 - 7 of 7 Posts
Top