Team Chevelle banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Car is being resurrected from sitting for 7 years. It was running last week. It has a 1970 307 motor. Changed the oil, oil filter and spark plugs. Now it won't start. Bought new battery, battery cables, spark plug wires, alternator and starter. Cap/rotor/points and condensor replaced about 3 months ago.

Now it will not even turn over. The lights/etc. are working---just not turning over. Any thoughts? I appreciate any info.
 

·
Registered
Joined
·
1,315 Posts
Start with the simple stuff. Bypass the neutral safety switch to eliminate it as a possible problem. Remove, clean, and reinstall the battery cables. Make sure your body to frame grounds are in place. Many GM vehicles use a short wire from the negative battery cable to the body.
If this doesn't help, move on to the difficult stuff like ignition switch and fusable links.
 

·
Premium Member
Joined
·
3,013 Posts
I would check the battery posts and make sure thay are clean and the cables have a good connection. If the starter soleniod dose not even click, check the wire connections at the starter. Could be the ignition switch also.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
Thanks everybody. Most of the things we had already done. New Battery, new battery terminals, new spark plugs and Wires, distributor, points, condensor, and so on.

Jumped the neutral safety switch and it turns over, so looks like that could be the problem (knock on wood).
 
1 - 9 of 9 Posts
Top