Chevelles.com banner

1 - 5 of 5 Posts
F

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My lights dont come on and sometimes it doesnt start, wont even turn over. the strange thing is the rear lights and sides come on fine, just no fronts. changed out the fuses and cleaned the battery terminals, everything seems to be plugged in.... im dead lost... someone help! thanks...

------------------
Phil
 

·
Registered
Joined
·
7,762 Posts
You mean the front headlights don't come on? Or is it the front running lights on the end of the fender that don't come on?
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #3
yeah just the very front headlights, all the other lights dont come on, had a similar problem before and turned on high beams and they clicked on but they dont, im wondering if a fuse could have burned and fried out both front lights... its really odd. i cant drive at night though, this sucks
 

·
Registered
Joined
·
7,762 Posts
See if you have voltage to the front headlights when you pull the headlight switch on. You should be able to get at the connector for the right light without removing the bulb. Open the hood and you can get at the headlight connector. Check both the high and low beam wire.
*EDIT*
Jeez, I said right headlight and meant the left one.


[This message has been edited by John_Muha (edited 07-24-2002).]
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #5
my voltage tester is busted! ill test the wires tommorow and make another post, thanks for the info so far!
 
1 - 5 of 5 Posts
Top