Team Chevelle banner
1 - 4 of 4 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 ·
after removing park lights in bumper & bumper from my 70 elco, whats the trick to get them back in place & reinstall bumper. wires dont unplug from lamp housing & lights dont fit through bumper suport brackets & are to short to run under brackets. must take at least two guys to mount the bumper? any suggestions from anybody who has done this. thx.
 

·
Premium Member
Joined
·
8,639 Posts
I just mounted the front bumper on my 70 Camino. Here is how I removed it.
Un-plug turn/park. I got two milk crates, one under each side of the bumper (under the park lights), shim with wood/whatever so you are touching the bumper.
In the center Hyd. floor jack at the peak. (under the bottom of bumper)
Unbolt the four bolts and slide it out, a little at a time. pull the right side out an inch or so, then the left, then the right. Slide the milk crates WITH the bumper, The floor jack is holding the center and rolling out with the crates. Dont forget to remove the rubber bump stops.
I installed it the same way, With the bumper irons attached.
NO falling down, NO banging the paint, NO rush to finish.
I think this is a very good and safe way to do this. I do not have HELPERS so I rig up safe ways to do stuff !
Bob:thumbsup:
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #3 ·
i looked at he lights/wires & could not find a disconnect point. seem to be attatched perm. to lamp assm. were do ya disconect them? the rest should be cake. thx. john
 

·
Premium Member
Joined
·
8,639 Posts
Follow the park/Turn wire to the engine side of the harness, Just above the inner fender. The plug has a lock on it, Use a weee little screwdriver to unlock it and pull it apart.
Bob:thumbsup:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top