Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part JULY's Ride of the Month Challenge!
1 - 11 of 11 Posts

·
Premium Member
Joined
·
12,727 Posts
Discussion Starter · #1 ·
I am missing all the positive battery cable clips on my 69. I see some places are selling the clips that bolt to the oil pan. So I have a couple questions on the clips and a general question.

Does anyone have a picture of the clip that mounts to the frame and holds the battery cable?

Without ever paying attention to this frame clip is that clip available anywhere or is there a suitable substitute somewhere?

As far as the clips that mount to the oil pan should they be black or orange?

The part number from the assembly manual for the frame clip is 3732015 and it's attaching screw is 9420152. Is there any advantage to obtaining part numbers from the assembly manual. Most times when I search them I come up blank. Is there any way to cross reference (in general) numbers from the manual.
 

·
Premium Member
Joined
·
12,727 Posts
Discussion Starter · #2 ·
Ttt
 

·
Premium Member
Joined
·
12,727 Posts
Discussion Starter · #3 ·
Once again.
 

·
Premium Member
Joined
·
4,277 Posts
PM me your email.

I will get under the car tonight or tomorrow and get the pictures.
 

·
Premium Member
Joined
·
12,727 Posts
Discussion Starter · #6 ·
Thanks Dean. Right now I can only look on my phone. Tomorrow I will be able to blow it up on my lap top.
 

·
Premium Member
Joined
·
1,291 Posts

Attachments

·
Premium Member
Joined
·
4,277 Posts

·
Premium Member
Joined
·
12,727 Posts
Discussion Starter · #10 ·
Thanks guys for all your efforts. I acquired two of the clips.that go to the oil pan and support the cable. Those are reproduced so just picked them up from Summit. In reading past threads about the clips.it was suggested that the frame mounted clip was rubber lined but it doesn't appear so. I believe the bolt for the frame clip is still in my frame and a small piece of the clip is still attached. It looks like the majority of the clip is broken off.
 

·
Premium Member
Joined
·
4,277 Posts
On my car, each clip is rubber coated, except for the ends where the bolt goes through.
 
1 - 11 of 11 Posts
Top